Система по обработке объявлений

http://www.psv73.com

E-mail: sergey@psv73.com

Тел./факс (0622) 97-80-66

© Сергей Пономаренко, 1999-2002 г.


Назначение и основные функции программы

Программа предназначена для оперативного сбора и обработки информации по телефону с дальнейшим экспортом данных для размещения в издательских системах (Corel Ventura, PageMaker).

Программа позволяет заносить объявления с использованием справочника часто используемых фраз и выражений. Контролировать номера телефонов, на которые даются объявления, на наличие их в справочнике запрещенных. А так же осуществляется контроль телефонов, на которое возможно размещение не ограниченное количество объявлений.

Мощный инструмент Справочник рубрик позволяет менять справочник рубрик как угодно, без потери занесенных объявлений.

При занесении нового объявления программа проверяет существуют ли объявления занесенные на этот номер телефона и если таковые имеются, то программа показывает их содержимое и Вы можете либо исправить существующие объявления, либо продолжить занесение нового (см. раздел Новое объявление)

Поддерживаются три типа объявлений - Бесплатные, Платные и Льготные. В свою очередь Платные и Льготные могут иметь набор стилей.

Реализована мощная поисковая система поиск может осуществляться по самым различным критериям: по номерам телефонов, адресу, тексту к телефону, коду объявления и даже по содержимому объявлений (см. раздел Поиск). Реализована также возможность автоматического поиска и замены в текстах всех объявлений текущего выпуска.

В программе используется механизм контроля работы операторов. Благодаря этому механизму можно проследить за работой операторов. Из отчетов Просмотр выпуска, можно получить информацию о том кто из операторов последним работал с объявлением.

Результатом работы программы является экспорт данных. Экспорт может производиться в кодировках MS-DOS (866) и Windows (1251). Данные могут экспортироваться в текстовый файл с управляющими кодами для издательской системы Corel Ventura и без управляющих кодов. Есть так же возможность экспорта каждой рубрики в отдельный текстовый файл (для размещения в Internet).

Максимально автоматизировать процесс верстки можно экспортируя данные в Corel Ventura 8.0. Для этого в Corel Ventura достаточно один раз в публикации прописать свойства всех используемых стилей объявлений. При последующих процессах импорт текста Corel Ventura автоматически будет оформлять объявление в соответствии с его стилем (включая значки пред телефоном и адресом).


Управление и навигация

При работе с программой доступны следующие команды редактирования:

Ctrl+C — копировать выделенный фрагмент в буфер
Ctrl+X — вырезать выделенный фрагмент и поместить в буфер
Ctrl+V — вставить фрагмент из буфера
Home — начало текста
End — конец текста

Выделение:

Shift+стрелки управления — выделение фрагмента текста посимвольно
Shift+Ctrl+стрелки управления — выделение фрагмента текста словами

Перемещение от одного поля к другому или от одного элемента управления к другому осуществляется с помощью клавиши Tab (табулятор). Чтобы переместиться на один элемент управления (или на одно поле) назад — используйте комбинацию клавиш Shift+Tab.

Элементы управления с выделенными буквами можно выбирать не только мышкой, но комбинацией горячих клавиш. Так например нажать на кнопку [image] можно нажав на клавиатуре комбинацию клавиш Alt+Н (при этом учитывается включенная раскладка клавиатуры — если надпись сделана на русском языке, то и комбинация должна нажиматься со включенным русским языком)

Интерактивный поиск:

Список

и раскрывающийся список

поддерживают интерактивный поиск, т.е. поиск по первым введенным буквам. При этом временной интервал между вводом символов с клавиатуры не должен превышать 0,5 сек. Иначе дальнейший ввод с клавиатур будет расценен программой, как новый поиск. В списке поиск осуществляется по первому столбцу.

Раскрывающийся список можно раскрыть мышкой нажав на стрелочку справа списка. Либо нажатием комбинации клавиш на клавиатуре Alt+стрелка управления вниз или вверх, или просто SpaceBar (пробел).


Структура базы данных

В состав базы данных входят следующие файлы:

News.dbc — этот файл является базой данных, в котором описаны все входящие таблицы
News.dct — служебный файл, входящий в состав базы данных
News.dcx — индексный файл базы данных
Agent.dbf — Справочник агентов
ArhiveXXX.dbf — Архив выпуска (при добавлении нового выпуска данные старого копируются в этот файл), где XXX - номер соответствующего выпуска
BlackSp.dbf — Справочник телефонов
GlobalData.dbf — таблица, содержащая настройки программы
GlobUsers.dbf — Справочник пользователей
HArhiveXXX.dbf — Архив рубрик соответствующего выпуска (где XXX номер выпуска)
Logon.dbf — таблица, содержащая информацию о входе пользователей в программу и выходе из нее
MyHeading.dbf — Справочник рубрик
NewsPaper.dbf — Перечень выпусков
Notes.dbf — таблица в которой находятся объявления текущего выпуска
TablesId.dbf — таблица, содержащая информацию об уникальности индексов таблицы.
PStyle.dbf — Справочник стилей объявлений

Voc.dbf — Справочник типичных фраз и выражений

Таблицы, расположенные у каждого клиента:

Localdata.dbf — таблица, содержащая путь расположения базы данных (если Вы удалите этот файл, то программа не сможет самостоятельно обнаружить базу данных и предложит либо создать новую, либо подключиться к существующей).
RK.dbf — таблица, в которой записан регистрационный ключ к программе


Регистрация программы

Программа имеет встроенную систему защиты от несанкционированного копирования. При покупке программы, после ее установке Вам нужно будет зарегистрировать программу (связаться с разработчиком и получить ключи к программе).

Покупая программу Вы получите ключи к каждому установленному экземпляру программы, рассчитанные на оговоренное, при покупке, количество пользователей.

Для того, чтобы получить ключ к программе Вам нужно сообщить номер компьютера. Номер компьютера формируется из названия предприятия (фирмы). Чтобы получить номер компьютер Вам необходимо заполнить поле Название предприятия (фирмы). А в поле Кол-во пользователей указать количество пользователей, оговоренное при покупке. Полученный ключ, необходимо занести в поле Ключ к программе.

Кол-во пользователей — это количество пользователей, которые одновременно могут работать с базой данных. При этом в Справочнике пользователей, их может быть гораздо больше, но с программой одновременно смогут работать не более указанного в поле Кол-во пользователей. В программу не смогут одновременно войти два пользователя с одним и тем же именем!!!

По желанию, программа может быть установлена на большем количестве компьютеров, чем указано в поле Кол-во пользователей. Но при этом одновременно смогут работать с базой данных столько пользователей, сколько указано в поле Кол-во пользователей.


Создание базы данных

После установки программы, при первом ее запуске, программа выдаст сообщение:

На это сообщение нужно ответить положительно и нажать кнопку [image]. После этого откроется окно Select Directory, приглашающее выбрать папку, в которой нужно создать базу данных:

В нижней части окна находится список доступных дисков, на которых Вы можете создать базу данных. Если же Вы желаете создать базу данных на диске какой-либо машины в сети, то Вам необходимо выйти из программы Обработка объявлений (если Вы находитесь в окне Select Directory, то просто нажмите кнопку [image] ). С помощью [image] Проводника подключите нужный Вам сетевой диск. Запустить программу снова. На этот раз в окошке Select Directory, в списке дисков будет присутствовать и подключенный Вами сетевой диск.

После того, как Вы выбрали нужный диск, в списке доступных папок на диске выберите папку в которой Вы хотите создать базу данных и подтвердите свой выбор нажатием на кнопке


Подключение к существующей базе данных

Если базу данных по каким-либо причинам программа не в состоянии найти на прежнем месте, то Вам будет предложено создать новую или подключиться к уже существующей:

Чтобы подключиться к уже существующей базе данных, Вам нужно указать ее местонахождения. Для этого на вопрос Создать базу данных? необходимо ответить отрицательно нажатием кнопки [image] Появится окно Open с помощью которого Вы сможет найти существующую базу данных.

Если база данных находится на локальном диске, то в списке Папка укажите интересующий Вас локальный диск (подробнее см. пункт 4 нижеследующей инструкции). Если база данных находится на сетевом ресурсе, то Вам необходимо указать месторасположения базы данных в следующей последовательности:

1. В списке Папка выбрать Сетевое окружение.
2. В появившемся списке доступных рабочих групп выберите интересующую Вас рабочую группу.
3. В появившемся списке компьютеров, доступных в выбранной рабочей группе выберите компьютер, на котором создана база данных.
4. В списке доступных ресурсов выберите диск на котором расположена база данных.
5. В отразившемся содержимом выбранного диска найдите папку, в которой находится база данных.

Если Вы правильно указали папку в которой находится база данных то в списке доступных файлов в этой папке, Вы увидите файл News.dbc.

Выберите этот файл и нажмите кнопку


Вход в систему

Вход в программу

Программа имеет средства защиты от несанкционированного доступа. В программу могут попасть только пользователи, занесенные в Справочник пользователей программы. Чтобы войти в программу Вы должны "назвать себя":

для этого Вам нужно в поле Имя: написать имя, присвоенное Вам, а в поле Пароль: Вам нужно указать Ваш личный пароль.

Имя и Пароль присваиваются администратором.

Для подтверждения входа в систему нажмите Enter или кнопку

ВНИМАНИЕ!!! В программе не возможно зарегистрироваться дважды с одним и тем же именем!!!

!!!Примечание: при первом запуске программы Справочник пользователей содержит одну единственную запись, позволяющую войти в программу. На предложение программы Назовите себя:

в поле Имя: нужно написать - Admin
поле Пароль: - остается пустым


Основные настройки

Окно Основные настройки содержит три страницы:

Экспорт

Оформление

Настройки

Страница Экспорт

"Шапка" для текстовых файлов, используемая при экспорте данных в Интернет - в это поле заноситься заголовок, который будет вставляться в каждый экспортируемый файл (см. Экспорт данных Для размещения в Интернет).

Первое слово БОЛЬШИМИ буквами - при экспорте данных первое слово каждого объявления будет экспортироваться большими буквами. Эта опция касается только объявлений Без стиля.

Далее следует раздел "Символы, подставляемые при экспорте данных в Corel Ventura".

При экспорте данных создается текстовый файл, в который автоматически могут подбрасываться управляющие коды. Рассмотрим на примере (данные экспортируются из формы "Экспорт данных", с установками: Кодировка — Windows 1251, и Формат данных — Текст для Corel Ventura):

Вот так будет выглядеть текст, если для телефона и для адреса установлены флажки "Не подставлять шрифт", а в поле образец для телефона написано Тел.:, а в поле образец для адреса - Адр.:

<B>Дом,<W0> Ленин. р-н, Боссе, 60 кв.м, газ, вода, х/постр., 4 сот. Тел.: 665497.
<B>Дом,<W0> Ленин. р-н, Боссе, флигель, лет.кух., 4 сот. Адр.:Д-5, Пухова, 145.

А вот так будет выглядеть экспортируемый текст, если флажки "Не подставлять шрифт" не установлены, и в поле образец для телефона установлен символ *, а в поле образец для адреса установлен символ &

<B>Дом,<W0> Ленин. р-н, Боссе, 60 кв.м, газ, вода, х/постр., 4 сот. <F"ZapfDingbats BT">&<F255>665497.
<B>Дом,<W0> Ленин. р-н, Боссе, флигель, лет.кух., 4 сот. <F"Wingdings">*<F255>Д-5, Пухова, 145.

В Corel Ventura вместо * и & в тексте будут подставлены символы соответствующих шрифтов (на картинке это значок телефона [image] и значок конверта [image]).

Отделять пробелом - текст (символ) подставляемый перед телефоном (адресом) указанный в поле Образец будет отделяться от номера телефона (адреса) пробелом.

На странице Экспорт, выбирая нужны шрифт с помощью кнопки [image], и занося текст в поле Образец, Вы можете подобрать интересующий Вас символ.

Страница Оформление

Основное окно программы содержит белый фон. Но Вы можете его разнообразить на свой вкус. Основное окно программы можно "заслать" картинкой или фотографией. Для этого нужно нажать кнопку [image]. В результате откроется окно, позволяющее найти файл, содержащий нужную картинку.

С помощью этого окна Вы сможете не только искать нужные файлы, но и сразу же их просматривать — для этого необходимо установить опцию Preview (просмотр будет работать в случае если нужные Вам файлы графические поддерживаются программой предварительного просмотра графических файлов - более детально см. список Тип файлов окна). Более детально о том, как искать файл см. раздел Подключение к существующей базе данных.

После того, как Вы нашли и "заслали" нужной картинкой основное окно, может возникнуть необходимость в растягивании картинки на все окно. Для этого служат опции Как отображать картинку. Экспериментальным путем, перебирая все опции, добейтесь нужного результата.

Если по каким-либо причинам Вы желаете очистить основное окно от установленной картинки, то для этого достаточно нажать кнопку [image]. И основное окно снова будет чистым.

Страница Настройки

Внимание!!! Все опции в этом окне доступны только если Вы вошли в программу с правами администратора.

В самом верху страницы "Настройки" расположено текстовое поле, отображающее Местонахождения базы данных к которой подключена программа. С помощью кнопки с троеточием [image] можно подключится к другой существующей базе данных (см. раздел подключение к существующей базе данных)

Начальная дата периода — здесь указывается начальная дата периода, которая будет автоматически устанавливаться в Просмотре выпуска. Эта дата должна быть меньше или равной дате самого "старого" объявления (обычно это объявлений категорий Платные и Льготные). Зафиксированная таким образом дата не позволяет выпустить из распечатки объявления, занесенные несколькими месяцами раньше (при условии, что эта дата не будет умышленно исправлена пользователем в окне Просмотр выпуска - что допускается). Откорректированная начальная дата в других окнах, отличных от окна Основные настройки — не запоминается и действует только до момента закрытия соответствующего окна. Изменить начальную дату с последующим ее сохранение можно только в окне Основные настройки.

Автоматически "0" — "ЗАМОРАЖИВАТЬ" - включите эту опцию, если Вы не хотите, чтобы объявления с количеством выходов ноль удалялись. В процессе присвоения нового номера объявления у которых количество выходов равно 0 будут заморожены.

Новые автоматически "ЗАМОРАЖИВАТЬ" - занесенное новое объявление автоматически будет замораживаться.

Поиск объявлений при внесении телефона - поиск, выполняемый при изменении номера телефона в объявлении. Возможны три варианта:

  1. Во всем выпуске - поиск указанного телефона будет осуществляться во всем выпуске.
  2. В указанной рубрике - поиск указанного телефона будет осуществляться только в указанной рубрике (в качестве рубрики берется основная рубрика без учета подрубрик).
  3. Не искать - поиск производиться не будет.

Максимальное количество выходов объявления: — опция, разрешающая устанавливать максимальное количество выходов объявлений категории Бесплатные. Эта опция распространяется на окна Новое объявление и Корректировка объявления в разделе Обработка объявлений. Если эта опция установлена, так как показано в примере - 3 раза, то в окнах Новое объявление и Корректировка объявления будут отражаться максимальное количество выходов 4, но доступны будут только 3:

Максимальная длина объявления (в символах) — по умолчанию 160. Здесь Вы можете задать максимальное количество символов в тексте объявления. Если Вам нужно заносить объявления неограниченного размера, тогда в этом поле, в качестве значения, укажите 0 (ноль).


Текущий выпуск

Новый выпуск
Корректировка
Сделать текущим
Удалить номер

Программа предназначена для обработки и подготовки данных для газет. Поэтому все объявления группируются по выпускам. Прежде чем заносить объявления нужно создать Новый выпуск.

Новый выпуск
Создается Новый выпуск нажатием кнопки

Программа ведет автоматическую нумерацию выпусков газеты. Нумерация ведется двойная: номер с начала издания и номер в текущем году — эта нумерация каждый год начинается заново.

Но по своему усмотрению, при добавлении нового номера Вы можете исправить предлагаемую нумерацию, на нужную. Дата автоматически присваивается путем увеличения даты выхода последнего выпуска на 7 дней.

Процесс создания нового номера заключается в сбрасывании текущего номера в архив и пересчете текущего.

Сбрасывание в архив заключается в создании таблиц ArhiveXXX.dbf, ArhiveXXX.fpt (таблица с объявлениями) и HArhiveXXX.dbf (таблица с рубрикатором), где XXX номер архивируемого выпуска. Прежде, чем проводить пересчеты количества выходов для объявлений текущий номер сбрасывается в архив и только после этого происходит пересчет количества выходов объявлений.

Пересчет заключается в уменьшении количества выходов объявления на 1 (... 3 становятся 2, 2 становятся 1, 1 становятся 0), при этом для объявлений с количеством выходов 0 применяется метод автоматического удаления — они на единицу не уменьшаются, а просто удаляются. Если в настройках программы установлена опция Автоматически "0" - "ЗАМОРАЖИВАТЬ", то объявления с количеством выходов 0 будут заморожены и останутся в новом выпуске.

Корректировка
Корректировка выпуска заключается в исправлении даты выхода, и нумерации выпуска (в случае ошибочного занесения). Корректировка доступна только для текущего выпуска! Исправление даты может быть полезным, когда сроки выхода газеты отодвигаются. Программа четко отслеживает дату выхода газеты. Например если администратор сделал экспорт данных, газету выпустили, но забыл создать новый выпуск, то на следующий день, когда операторы попытаются войти в окно Обработка объявлений программа выдаст сообщение о несоответствии дат. Чтобы решить эту проблему нужно либо создать новый выпуск, либо отодвинуть дату выхода газеты. Для того чтобы отодвинуть дату выхода газеты и дать возможность операторам обрабатывать текущий выпуск необходимо просто исправить дату выхода газеты. Сделать это можно нажав кнопку [image] (при этом никакие пересчеты количества выходов объявлений производиться не будут).

Сделать текущим
Если в результате некорректных действий администратора преждевременно был присвоен новый номер, то исправить это можно сделав нужный номер Текущим. Для этого в списке номеров выберите нужный номер и нажмите кнопку [image]. В результате текущий номер сбросится в архив (без пересчета количества выходов объявлений), а из архива извлечется выбранный номер и операторы смогут его обрабатывать.

Удалить номер
В процессе работы в архиве скапливается много объявлений, и файл архива очень быстро растет и может достигать нескольких сотен Мегабайт. Чтобы не хранить такие объемы не нужной информации ее можно удалять. Сделать это можно нажав кнопку [image]. Если Вы удалите текущий номер, то удалятся и все объявления в нем содержащиеся и Вам нужно будет Сделать текущим последний номер из архива.


Справочник рубрик

Как пользоваться справочником рубрик
Добавить рубрику
Вставить рубрику
Переименовать рубрику
Переместить рубрику
Удалить рубрику
Печать рубрикатора

Справочник рубрик имеет три степени вложенности:
1 - Основная рубрика
2 - Подрубрика 1-го уровня
3 - Подрубрика 2-го уровня

На примере это выглядит так:

Основная подрубрика - НЕДВИЖИМОСТЬ
Подрубрика 1-го уровня - Продам квартиру
Подрубрика 2-го уровня - Ленинский район

Основная рубрика может не иметь подрубрик (вложений), но вложения (подрубрики) без основной рубрики не могут существовать!!! Другими словами в рубрикаторе возможны следующие варианты вложенности рубрик:

а) только основная рубрика (без подрубрик 1-го и 2-го уровня);
б) основная рубрика с подрубриками 1-го уровня (подрубрики 1-го уровня не имеют подрубрик 2-го уровня);
в) основная рубрика с подрубриками 1-го уровня, которые в свою очередь имеют подрубрики 2-го уровня.

Рубрика имеет два названия. Одно — это название рубрики, используемое программой при работе со справочником рубрик при просмотре текущего выпуска, для отображения рубрики при занесении нового и корректировки существующего объявлений. Второе — используется исключительно при экспорте данных, т.е. в экспортируемом текстовом файле названия и особенности написания названий рубрик берутся из Второго названия рубрики (подрубрики). Эти названия могут как отличаться, так и быть абсолютно одиннаковыми. Но при добавлении новой рубрики (подрубрики) обязательно указывать оба названия.

Как пользоваться справочником рубрик

Примечание: в Справочнике рубрик, вызванном при занесении нового объявления, либо при корректировке существующего отсутствуют кнопки: , [image], [image] и [image], а вместо кнопки [image] установлены две кнопки: и [image].

Справочник состоит из двух списков. Для удобства будем их называть верхний (Список, отражающий выбранную рубрику и подрубрику) и нижний (Список, отражающий содержимое выбранной подрубрики).

Выбирать рубрику можно как с помощью мышки, так и с помощью клавиатуры.

1) с помощью мышки:

В верхнем списке выделите пункт Основная рубрика. В нижнем списке отразится весь перечень основных рубрик. Выберите основную рубрику путем двойного щелчка левой кнопки мышки на нужной Вам рубрике. При этом в нижнем списке отразятся все подрубрики 1-го уровня содержащиеся в выбранной Вами основной рубрике. В верхнем списке в пункте Основная рубрика отразится выбранная Вами основная рубрика, а в пункте Подрубрика 1-го уровня — отразится первая из подрубрик 1-го уровня, из нижнего списка (если же Основная рубрика не имеет подрубрик, то нижний список и пункт Подрубрика 1-го уровня в верхнем списке — будут пусты).

Выбрав Подрубрику 1-го уровня переходим к выбору Подубрики 2-го уровня (если таковые имеются). Для этого снова обращаемся к верхнему списку и выделяем пункт Подрубрика 2-го уровня а в нижнем списке выбираем нужную подрубрику.

б) с помощью клавиатуры

С помощью клавиатуры выбор рубрики осуществляется на много проще. Для этого сделайте активным нижний список (если нижний список активен, то при нажатии клавиш вверх и вниз курсор будет перемещаться по этому списку). Выберите нужную рубрику и нажмите Enter. В результате этого в верхнем списке в пункте Основная рубрика Вы увидете выбранную рубрику, а в нижнем списке появится перечень подрубрик 1-го уровня, относящиеся к выбранной рубрике (список будет пуст, если данная рубрика не имеет подрубрик). Если же Вы неправильно выбрали рубрику, то вернуться к списку рубрик можно нажав клавишу BackSpace.
Выбор подрубрики 1-го уровня осуществляется точно также, и в случае ошибочного выбора вернуться на один уровень назад можно с помощью клавиши BackSpace.

!!! Примечание: при работе со справочником рубрик при занесении нового объявления или корректировке существующего объявления, когда Вы в рубрике выбираете последнюю вложенность, то окно выбора рубрики автоматически закрывается.

Например:
Основная рубрика — Работа
Подрубрика 1-го уровня — Требуются

После того как Вы в нижнем списке выберите пункт Требуются (сделаете двойной щелчок мышью на этом пункте, либо нажмете Enter) — окно справочника рубрик автоматически закроется.

Добавить рубрику
Чтобы добавить новую рубрику нажмите кнопку [image] (для выполнения этой операции не имеет никакого значения в какой рубрике Вы находитесь). В окне Добавить рубрику укажите куда Вы хотите ее добавить:

— если это основная рубрика, то нужно указать Код основной рубрики, а Код подрубрики 1-го уровня и Код подрубрики 2-го уровня оставить пустыми (значения 0);
— если это подрубрика 1-го уровня, то нужно указать номер Основной рубрики (основная рубрика с указанным номером должна быть уже создана) и номер добавляемой подрубрики 1-го уровня, номер подрубрики 2-го уровня остается пустым;
— если это подрубрика 2-го уровня, то указываются все номера рубрик и подрубрик, при этом и Основная рубрика и Подрубрика 1-го уровня с указанными номерами должны быть уже созданы!!!

Кажда рубрика имеет свой код. Так добавляемая рубрика в приведенном выше примере (см. окно Добавить рубрику) будет иметь код: 3.2.3. и называться Программное обеспечение. Если Вы, при добавлении новой рубрики (подрубрики) укажете уже существующий код, то рубрика вставится на место существующей, с указанным кодом (см. Вставить рубрику).

Вставить рубрику
Иногда возникает необходимость вставить рубрику (подрубрику) между уже существующими. Для этого нужно нажать кнопку [image] в окне Справочник рубрик. В окне Добавить рубрику указать код вставляемой рубрики, занести оба названия рубрики и нажать кнопку [image] в окне Добавить рубрику. Если рубрика с указанным кодом уже существует, то программа выдаст предупреждение. Например добавим рубрику с кодом 3.1.3. Продукты:

В случае положительного ответа все существующие рубрики передвинутся и освободят место, на которое и добавиться новая. При этом объявления в перемещаемых рубриках не будут потеряны, потому как рубрики переместятся вместе со своими объявлениями.

Переименовать рубрику
В окне Справочник рубрик нажмите кнопку [image].

В окне Корректировать название группы исправьте прежнее название рубрики на новое и нажмите кнопку [image]. При корректировке названия рубрики поля кодов рубрики — не доступны для изменения (чтобы переместить рубрику см. Перемещение рубрики.)

Переместить рубрику
Эта операция состоит из двух: Вставить рубрику и удалить рубрику.

Сначала Вам нужно вставить рубрику с точно таким же названием в нужном месте. А затем удалить перемещаемую рубрику с переносом всех объявлений из удаляемой во вновь созданную.

Удалить рубрику
Выберите в нижнем списке рубрику (подрубрику), которую Вы хотите удалить и нажмите кнопку [image]. Есть два способа удаления рубрики (подрубрики):

Первый способ — это удаление выбранной рубрики вместе с содержащимися в ней объявлениями.

Второй способ — это удаление выбранной рубрики с переносом всех ее объявлений в любую другую из предложенных в списке:

В любом из этих случаев нумерация в рубрикаторе будет автоматически изменена с учетом удаления рубрики. При этом содержимое всех рубрик и подрубрик (объявления относящиеся к ним) будет сохранено.

Печать рубрикатора
Чтобы распечатать рубрикатор достаточно нажать кнопку [image]. Появится окно предварительного просмотра, в котором Вы сможете просмотреть рубрикатор, и панель инструментов с кнопками перемещения по страницам и кнопкой печати:

Если Вы согласны с содержимым, то нажмите кнопку с принтером и документ отправиться на печать.


Справочник стилей

В программе реализован механизм поддержки большого количества стилей (до 100). Стили - это используемые в издательской системе (PageMaker, Corel Ventura) правила оформления абзацев (в нашем случае).

В самой программе нет настроек, позволяющих полностью настроить все свойства стиля. Здесь настраиваются только те свойства, которые в издательской системе приходиться настраивать в ручную (такие как: выделение первых нескольких слов соответствующим образом, разбиение одного объявления на два стиля, перевод текста объявления в верхний регистр и т.д. ). А основные настройки конкретного стиля - осуществляются в используемой издательской системе. В качестве издательской системы рекомендуется Corel Ventura 8.0.

Название стиля - список используемых стилей. Стили используются только для "Платных" или "Льготных" объявлений. Они далеко не все могут использовать какой-то стиль. Большинство их них могут использовать стиль, установленный по умолчанию в издательской системе (такая ситуация может возникнуть, когда в газете могут быть платными не все рубрики, а только некоторые из них). Для этого предназначена в списке запись "Без стиля".

Кнопка [image] позволяет добавить новый стиль:

Полное название стиля — название, используемое для отображения доступных стилей в списках стилей программы.

Название стиля для экспорта — это название будет подставляться при экспорте в текстовый файл. Стиль с таким же именем должен быть настроен в издательской системе, в которую экспортируются данные.

Сокращенное название стиля — используется для отображения названия стиля в отчетах (Просмотр выпуска).

Чтобы занести сохранить новый стиль нужно обязательно указать все 3 названия.

Весь текст объявления большими буквами — установите эту опцию, если Вы хотите, чтобы при экспорте данных все объявления выбранного стиля автоматически переводились в верхний регистр.

Использовать выделение внутри текста объявления — позволяет заключить первых несколько слов между управляющими кодами издательской системы.

Выделит первых слов — указывается сколько слов нужно заключить между управляющими кодами.

На примере выше, выделяется первое слово — команда <BA> жирный шрифт, верхний регистр. Команда <W0> отменить установленные до этого команды. Более подробный список используемых команд вы можете узнать из документации к используемой издательской системе. Либо просто в издательской системе оформить нужным образом текст и экспортировать его в текстовый файл с управляющими кодами и изучить используемые команды.

Отделять выделение от основного текста — включение этой опции предполагает автоматическое создание дополнительного стиля. Благодаря этой опции можно создавать такие типы оформления объявления:

Объявление разбивается на 2 абзаца и при этом каждый из абзацев может иметь свои настройки, отличные другого. В нашем примере первый абзац будет обладать свойствами стиля Type 3, а второй абзац будет обладать свойствами стиля Type 3-1 (свойства этих стилей настраиваются в издательской системе).

С помощью кнопок [image] и [image] Вы можете перемещать по списку стили для достижения нужной Вам последовательности.


Справочник агентов и диспетчеров

Обрабатывая объявления (занесение, корректировка), при изменении телефона программа проверяет наличие объявлений на указанный номер и показывает все объявления, занесенные на этот номер телефона. Но может возникнуть ситуация, когда нужно заносить очень много объявлений на один номер телефона и при этом абсолютно не важно есть ли объявления занесенные на этот номер телефона. В этом случае может помочь справочник агентов и диспетчеров. Если указанный в объявлении телефон есть в справочнике, то выдастся предупреждение:

при этом поиск среди объявлений производиться не будет.

Добавляются объявления в справочник путем нажатия кнопки [image]. При добавлении нового телефона программа осуществляет поиск в справочнике на наличие указанного телефона. Если заносимый телефон уже существует в списке, то программа выдаст предупреждение:

И Вам будет предложено исправить указанный номер телефона.

Чтобы исправить имя Владельца телефона необходимо выбрать в списке нужную Вам запись и нажать Enter или кнопку [image]. В появившемся окне Корректировка имени владельца в поле Диспетчер будет указано выбранное имя

Исправьте существующее имя на нужное и нажмите кнопку [image]. В результате в списке имя обновиться на новое. В процессе корректировки имени поле Телефон — не доступно. Если же Вам нужно исправить телефон, то удалите с неправильным телефоном и добавьте новую, указав правильный телефон.

Удаление записей из списка осуществляется путем выделения нужной записи в списке и нажатием кнопки [image].

Список может сортироваться как по телефонам, так и по именам Владельцев:
— чтобы сортировать список по телефонам необходимо щелкнуть мышкой на заголовке столбца № телефона (кнопка [image]);
— чтобы сортировать список по именам владельцев, щелкните на заголовке столбца Владелец (кнопка [image]).

Имеется возможность вывести список на экран [image] или на принтер [image].


Справочник запрещенных телефонов
Добавление
Корректировка
Удаление

При занесении объявлений в программу может возникнуть необходимость в проверке заносимых телефонов. К примеру Вы не желаете, чтобы в рубрике Работа бесплатно размещали объявления Кадровые агентства. Для этого Вам достаточно указать телефоны агентства в этом справочнике, как запрещенные в рубрике и эти телефоны не останутся незамеченным при занесении объявлений.

По смыслу своему справочник телефонов — это череный список. При занесении новых объявлений программа осуществляет поиск указанного телефона в справочнике телевонов, и если в справочнике будет обнаружен этот телефон — программа выдаст предупреждение.

Добавление
В справочник телефонов можно заносить как номера телефонов запрещенные во всех рубриках, так и в конкретно выбранной.

Чтобы занести телефон запрещенный во всех рубриках нужно:
1. Опцию Показать № телефонов, чьи объявления не должны печататься установить В газете.
2. Нажать кнопку [image].
3. В окне Добавить телефон в поле Телефон указать заносимый номер телефона, а в поле Владелец - комментарий к телефону.

Если в списке уже имеется указанный телефон, то программа выдаст соответствующее сообщение:

что поможет избежать многократного ввода одних и тех же данных, и Вам будет предложено исправить номер заносимого телефона.

Занесение телефона, запрещенного в рубрике, осуществляется аналогично, за исключением опции Показать № телефонов, чьи объявления не должны печататься — нужно выбрать пункт В рубрике.

Если в список запрещенных В рубрике будет заноситься телефон, который уже есть среди запрещенных В газете или в выбранной рубрике — программа выдаст соответствующее сообщение.

Корректировка
В справочнике телефонов можно корректировать только комментарий к телефону. Корректировка комментария осуществляется нажатием кнопки [image]. Если же Вам нужно исправить существующий номер телефона, то для этого Вам нужно удалить этот телефон и занести новый.

Удаление из списка осуществляется путем выделения нужной записи в списке и нажатием кнопки [image].

Список может сортироваться как по телефонам, так и по Комментарию:
— чтобы сортировать список по телефонам необходимо щелкнуть мышкой на заголовке столбца № телефона (кнопка [image]);
— чтобы сортировать список по именам владельцев, щелкните на заголовке столбца Комментарий (кнопка [image]).


Справочник типичных фраз и выражений

Добавить выражение
Корректировать выражение
Удалить выражение

Справочник типичных фраз и выражений создается на основании только основных рубрик (в программе не реализована возможность вести справочник типичных фраз и выражений для подрубрик)

К заполнению справочника можно приступать только после того, как сформирован справочник рубрик.

Добавить выражение:
1. Выбрать рубрику, к которой вы хотите отнести новое выражение, фразу.
2. Нажать кнопку
3. В окне Добавить новую фразу в поле написать новое слово, фразу...

4. Нажать кнопку [image]. В списке фраз и выражений добавленное Вами выражение выделится.

Корректировать выражение
Чтобы исправить неправильно введенное слово или выражение необходимо выбрать его в списке занесенных фраз и выражений и нажать кнопку [image].

В окне Корректировка фразы

исправить существующее выражение на нужное и нажать кнопку [image]. В списке, исправленное выражение будет обновлено и выделится.

Удалить выражение

Удаление не нужного выражения из справочника осуществляется путем нажатия кнопки [image].


Справочник пользователей

Добавить нового
Исправить существующего
Удалить

В этот справочник заносятся пользователи, которым разрешен доступ в программу.

Список можно сортировать по все трем столбцам: по имени, Полному имени, по статусу. Для того, чтобы отсортировать по нужному критерию, нажмите соответствующую кнопку в заголовке столбца.

Добавить нового пользователя
Добавление нового пользователя осуществляется нажатием кнопки [image]. В появившемся окне Новый пользователь нужно указать Имя пользователя, Полное имя пользователя и Пароль.

Если Вы хотите новому пользователю предоставить права администратора, то необходимо включить опцию Администратор.
Заполнение поля Полное имя пользователя не является обязательным, оно носит информационный характер.

Пароль устанавливается путем заполнения поля Пароль и поля Подтверждение. Пользователь будет добавлен в справочник пользователей при условии, что введенный набор символов в полях Пароль и Подтверждение — идентичны. Пароль может отсутствовать, для этого при добавлении нового пользователя, либо корректировке существующего, поля Пароль и Подтверждение нужно оставить пустыми.

Пароль должен состоять только из букв (допустим русский и латинский алфавиты) цифры и знаки пунктуации игнорируются.

Внимание!!! В список пользователей не возможно занести с одним и тем же именем, более одного пользователя!

Корректировать данные
Изменение данных пользователя осуществляется нажатием кнопки [image]. Изменить можно все данные, включая и его Имя. Но при этом все объявления обработанные прежним пользователем будут числиться за новым.

Удалить пользователя
Чтобы удалить пользователя, нужно выбрать его в списке и нажать кнопку [image]. Если в текущем выпуске есть объявления, обработанные удаляемым пользователем, то программа выдаст соответствующее сообщение. Чтобы удалить такого пользователя, Вам придется подождать несколько выпусков, пока все его объявления "уйдут" из текущего номера. Либо откорректировать все объявления, обработанные удаляемым пользователем.


Обработка объявлений

Основное окно, с которым Вам придется работать при занесении и корректировке объявлений это окно Обработка объявлений.

В этом окне отображается вся необходимая информация. В заголовке окна Вы сможете увидеть имя, под которым Вы зарегистрировались в системе (в данном случае это Admin). В списке отображены все занесенные объявления. Объявление в списке с пустыми телефоном и текстом объявления — это объявление, которое заносить кто-то из пользователей в текущий момент.

В окне Обработка объявлений доступны следующие "горячие клавиши":

+ — Добавить новое объявление
- — Вызов окна Удалить для удаления объявлений
Delete — Вызов окна Удалить для удаления объявлений, с автоматическим помещением номера выбранного объявления в список удаляемых.
ENTER — корректировка выбранного объявления
F7 — Вызов окна Поиск
F6 — продолжить поиск, по данным предварительно занесенным в окне Поиск
ESC — закрыть окно Обработка объявлений

Примечание: ENTER срабатывает только если активным элементом управления является список объявлений.

Добавление нового объявления осуществляется следующими способами:
1) Нажатием кнопки [image].
2) Нажатием на клавиатуре клавиши "+".

Вызов объявления для Корректировки тоже может осуществляться нескольким способами. Выберите нужное объявление в списке объявлений и выполнить одно из ниже перечисленных действий:
1) Нажать кнопку [image].
2) Выбрать нужное объявление в списке и нажать клавишу Enter.
3) Выполнить двойной щелчок мышкой на нужном объявлении в списке.

Удалить объявление можно:
1) Нажав кнопку [image] или клавишу "—" на клавиатуре вызвать окно Удаление и в нем удалить нужные объявления.
2) Выбирая в списке нужные объявления нажимать клавише Delete на клавиатуре. В результате выбранные объявления будут автоматически заноситься в список удаляемых в окне Удаление (при этом Вам будет также доступен и поиск — F7).

Поиск обявления можно выполнить нажав:
1) Кнопку
2) Функциональную клавишу F7 на клавиатуре.

Продолжить поиск по данным, предварительно занесенным в окне Поиск, можно следующими способами:
1) Нажать кнопку
2) Нажать функциональную клавишу F6 на клавиатуре.


Занесение нового объявления

Занесение номера телефона
Объявление без адреса и телефона
Занесение текста объявления
Выбор категории объявления

При занесении нового объявления выполняется автоматическая нумерация объявлений. В основу автоматической нумерации объявлений положен принцип повторного использования удаленных номеров. Т.е. при добавлении нового объявления происходит поиск отсутствующих номеров и если таковые имеются, то программа их автоматически восстанавливает и присваивает новым объявлениям.
Например: было занесено объявление под номером 3584 с количеством выходов 2. Через 3 выхода объявление автоматически удалиться из базы и номер, числившийся за ним освободится. При добавлении нового объявления программа найдет освободившийся номер 3584 и присвоит его новому объявлению. Если же освободившихся номеров больше нет, то программа продолжит нумерацию.

Таким образом в каждом выпуске поддерживается уникальная нумерация объявлений и при этом происходит очень быстрое добавление новых объявлений (что очень важно при работе в сети).

Если же Вы каждый раз продлеваете количество выходов объявления, то это объявление будет всегда иметь тот же самый номер, до тех пор, пока оно не будет удалено автоматически (по завершению количества выходов), либо пока его не удалит Администратор.

При добавлении нового объявления (см. раздел Обработка объявлений), автоматически появляется окно Справочник рубрик, предлагающее выбрать рубрику для заносимого объявления.

После того как Вы выберите нужную рубрику Вам нужно будет занести все оставшиеся данные касающиеся объявления. Если же Вы находясь в Справочнике рубрик нажмете кнопку [image] либо клавишу Esc (на клавиатуре), то Вы вернетесь в окно Обработка объявлений.

При занесении нового объявления обязательно должны быть заполнены следующие поля:
— указан один из телефонов либо адрес;
— занесен текст объявления;

Если все обязательные поля заполнены, то кнопка [image] станет доступной и примет вид [image].

Объявление без адреса и телефона
Но могут быть объявления, которые не содержат ни адреса, ни телефона:

Утерянное удостоверение Ветеран труда №351174 на имя Цыганкова Леонида Ванифатовича считать недействительным

Для того чтобы занести такое объявление нужно установить опцию Объявление без адреса и телефона.

Занесение номера телефона. Программа позволяет указывать два номера телефона, для одного объявления — поля Телефон1 и Телефон2. При занесении номера телефона происходит автоматический поиск указанного номера (см. настройки поиска если выбрана опция "Не искать" то поиск среди объявлений производиться не будет) в Справочнике агентов и диспетчеров и в Справочнике телефонов. Если указанный номер телефона обнаружен в Справочнике агентов и диспетчеров, то программа выдаст соответствующее сообщение:

При этом дальнейший поиск телефона в справочниках, а также в базе на наличие занесенных объявлений на этот номер телефона, производиться не будет!!! И после этого сообщения Вы сразу же перейдете к набору текста объявления.

Если в Справочнике агентов и диспетчеров телефон не обнаружен, программа проверит Справочник телефонов, на наличие указанного телефона в этом справочнике. И если там этот телефон существует, то программа выдаст подобное сообщение:

Если и в Справочнике телефонов указанный телефон не обнаружен, то программа выполнит поиск объявлений, занесенных на этот номер телефона в этой же рубрике. И если таковые имеются, то программа выдаст соответствующее сообщение:

Программа выдаст подобное сообщение для каждого объявления в выбранной рубрике с указанным номером телефона. Если ответить "Нет" программа продолжит поиск объявлений с указанным номером. "Отмена" - поиск будет прерван.

Занесение текста объявления
В поле Содержание объявления заноситься непосредственно текст объявления в таком виде, в коком он долен быть размещен в публикации. При занесении текста объявления Вы можете пользоваться Справочником стандартных фраз, использование которого может существенно увеличить скорость занесения текста объявлений (особенно если используется выработанная система обозначений и сокращений). Вызвать этот справочник можно нажав функциональную клавишу на клавиатуре F2.

Выбор категории объявления
Предусмотрены три категории объявлений: Бесплатное (максимальное количество выходов этой категории 4, и может регулироваться Администратором в меньшую сторону), Платное и Льготное. Количество выходов объявлений категорий Платное и Льготное — 999. Для категории Бесплатные установление количества входов осуществляется выбором опции Количество выходов:

А для объявлений категорий Платные и Льготные количество выходов вносится в текстовом поле расположенным по опциями Количество выходов.

Стиль — доступно для объявлений категории Платные или Льготные. В этом списке Вы можете выбрать доступные стили оформления объявления (см. Справочник стилей).

Опция Не прозванивать используется в отчетах формируемых в окне Просмотр выпуска.

Заморозить — замораживает объявление. Замороженное объявление не участвует в экспорте данных.

Занесение объявления в базу данных осуществляется нажатием кнопки [image], либо нажатием клавиши F10 на клавиатуре. При этом на занесенном объявлении устанавливается Ваша метка и это объявление числится как обработанное Вами до тех пор, пока кто-нибудь другой не откорректирует его (это используется в отчетах Анализ по операторам, Просмотр выпуска и Удалить данные по оператору).


Корректировка объявления

При корректировке объявления изменение категории объявления (в окне это Тип объявления:) не возможно. Тип объявления выбирается только при занесении нового объявления. Если же Вам нужно изменить категорию объявления, то Вам придется удалить его и добавить такое же новое, но указав правильную категорию (Бесплатное, Платное или Льготное).

Если объявление имеет тип Бесплатное то для изменения количества выходов можно воспользоваться комбинацией клавиш Alt+1, Alt+2, Alt+3, Alt+4.

При корректировке объявлений категорий Платное и Льготное возможность изменения количества выходов доступна только Администратору.

Все остальные поля обрабатываются точно так же, как и при занесении нового объявления.


Поиск объявлений

Поиск может осуществляться по различным критериям.

1. По телефону:
Выбрав этот критерий и указав в поле Введите значение для поиска: искомый номер телефона Вы можете организовать поиск объявлений, занесенных на указанный номер телефона. При этом поиск будет производиться как по полю Телефон1, так и по полю Телефон2 (см. раздел новое объявление).

Если же программа в текущем выпуске не найдет ни одного объявления с искомым номером телефона, она произведет поиск этого телефона и в Справочнике телефонов. И если в этом справочнике искомый телефон будет обнаружен, то программа выдаст соответствующее предупреждение.

2. По коду объявления:
По коду объявления осуществляется самый быстрый и точный поиск (без перебора не нужных объявлений). Данные о кодах объявления Вы можете получить из отчетов сформированных в окне Просмотр выпуска. Например, распечатав какую-либо из рубрик Администратор просматривает ее и находя ошибки в занесенных объявлениях, организовывает поиск объявления с ошибками по коду и исправляет ошибки.

3. По адресу:
Этот критерий полезен, когда клиент размещая свое объявление, в качестве координат оставлял не телефон, а к примеру, абонентский ящик.

4. По тексту к телефону:
Может возникнуть ситуация, когда в качестве телефона задается номер телефона оператора пейджинговой связи, а в качестве Текста к телефону указывается номер пейджера. Тогда найти этого клиента очень просто организовав поиск по этому критерию, указав в качестве искомого значения номер пейджера.

5. В объявлении:
Здесь речь идет о поиске в тексте объявлений. Например пользователи при занесении объявлений неправильно указывали название техники:
есть JVC — производитель аудио-видео техники, а есть GVC — производитель модемов. В данном случае не возможно применить автоматический поиск и замену, потому как возможен и тот и другой вариант, поэтому вам лучше организовать поиск по этому критерию с указанием нужного значения и то что не соответствует действительности исправить.

Если объявление с искомыми параметрами будет обнаружено, то в окне Обработка объявлений в списке объявлений высветится строка с объявлением, удовлетворяющим условиям поиска. С помощью кнопки [image], в окне Обработка объявлений, Вы можете продолжить поиск объявлений удовлетворяющих искомым параметрам (при поиске по коду объявления кнопка [image] — недоступна, потому как нумерация объявлений уникальна, см. раздел Новое объявление).


Поиск и замена

Возможна ситуация, когда необходимо произвести автоматическую замену каких-либо слов или выражений во всех объявлениях их содержащих. Например изменилась система сокращений — Вы сможет легко и быстро это исправить с помощью поиска и замены.

При этом будут исправлены все выражения в объявлении (в поле Найти: комн., в поле Заменить на: к.):
3-комн.кв. на 1-комн.кв.+2-комн.кв. или 1-комн.кв.+1-комн.кв.+доплата. Тел.:335-25-35.
после поиска и замены:
3-к.кв. на 1-к.кв.+2-к.кв. или 1-к.кв.+1-к.кв.+доплата. Тел.:335-25-35.

С помощью поиска и замены можно не только заменить, но и удалить выражения. Для этого в поле Найти: нужно указать искомое выражение, а поле Заменить на: — оставить пустым.

Внимание!!! Эта функция доступна только Администратору.


Удаление объявлений

В поле Введите № объявления набираете номер удаляемого объявления и нажимаете клавишу Enter. При этом код объявления автоматически добавляется в список удаляемых, и программа сразу же готова к вводу нового кода объявления.

Если Вы ошибочно указали не тот код объявления, удалить его из списка удаляемых можно дважды щелкнув на нем мышкой, либо выбрать его в списке мышкой и нажать клавишу Enter.

Очистить весь список без удаления объявлений из базы можно нажав кнопку [image].

Чтобы удалить из базы все объявления, занесенные в список удаляемых достаточно нажать клавишу [image].
При этом список удаляемых объявлений будет автоматически очищаться (коды удаленных объявлений будут удаляться и из списка). Процесс удаления объявлений завершается выводом окна сообщающего о количестве удаленных и не удаленных объявлений (при этом в списке удаляемых объявлений останутся объявления, которые не были удалены по каким-либо причинам).

Если в процессе удаления объявлений, среди удаляемых будет обнаружено Платное объявление, программа выдаст сообщение:

Если Вы ответите Да, то это объявление будет удалено и автоматически будет продолжено удаление объявлений в соответствии со списком удаляемых объявлений.

Если Вы ответите Нет, то это объявление не будет удалено, но автоматически будет продолжено удаление объявлений в соответствии со списком удаляемых объявлений.

Если же Вы нажмете кнопку [image], то процесс удаления объявлений будет прерван.

Тоже касается и объявлений категории Льготное.


Удаление данных по оператору

Эта возможность может оказаться очень полезной, если Вам по каким-либо причинам нужно удалить все объявления занесенным определенным пользователем или пользователями (на пример после экспериментов Вы решили почистить базу с объявлениями)

Чтобы выделить в списке одного пользователя Вам достаточно найти его в списке и выбрать его имя в списке мышкой.

Чтобы выделить весь список Вам нужно нажать клавишу Shift на клавиатуре и, не отпуская ее, найти самого первого оператора в списке и выделить его. Дальше, не отпуская клавишу Shift, найдите самого последнего пользователя в списке и выберите его. При этом весь список будет синим.

Чтобы выделить выборочно — нажмите на клавиатуре клавишу Ctrl (Control) и, не отпуская ее, мышкой в списке выбирайте нужных Вам пользователей. Чтобы снять выделение со случайно выделенного пользователя — не отпуская клавишу Ctrl выберете его мышкой.

Чтобы снять выделение со всех выделенных пользователей — щелкните мышкой на любом пользователе в списке (клавиши Shift и Ctrl должны быть не нажаты). При этом выделится этот пользователь, а со всех остальных выделение снимется.

Удаление объявлений занесенных или обработанных выбранными пользователями осуществляется нажатием кнопки [image].


Просмотр выпуска

Это окно предназначено для вывода объявлений текущего выпуска. Благодаря настройкам, расположенным в нем, Вы можете выбирать объявления нужной категории, с различным количеством выходов, используя различные сортировки, выбрав нужный период.

Тип объявлений — позволяет ограничить объявления, попадаемые в отчеты по категориям.

Сразу же под ними расположен список рубрик, позволяющий выводить объявления только указанной рубрики (подрубрики). Если же Вы хотите включить в отчет объявления всех рубрик, то Вам нужно включить опцию Все в группе опций Выводить рубрику.

Стиль — доступно, если Вы выбрали тип объявлений Платные или Бесплатные. В списке Вы можете выбрать интересующий Вас стиль объявлений. Если же Вас интересуют все стили объявлений, то Вам необходимо включить опцию Платные всех стилей.

Сортировать по рубрикам — все выводимые объявления группируются по рубрикам

Сортировать по телефонам — объявления не группируются, а в выводятся с сортировкой по номерам телефонов (при этом для сортировки используется телефон, занесенный в поле Телефон1 в окне Занесение объявления, объявления без телефонов в этот отчет не попадают). При включенной этой опции представляется так же возможность выводить объявления с указанием только кодов рубрик, а возможно с указанием названий рубрик. Для этого служит опция С названиями рубрик.

Опция сортировать по коду доступна только при выводе объявлений категорий Платные, Льготные и Выделенные. В этом случае объявления будут группироваться по рубрикам, а в рубриках они будут сортироваться не по алфавиту (тексту объявления), а по коду объявления.

Выводимые отчеты не имеют заголовков таблицы, что сделано для экономии бумаги, при выводе на печать.

Первый столбец — код объявления. Дальше следует дата и время последней корректировки объявления (если оно не корректировалось, то это дата его занесения). За этим полем расположен промежуток для меток "Н" (объявления с установленной меткой Не прозванивать), "П" — объявление категории платное, "Л" — объявление категории льготное (для более детальной информации см. разделы Новое объявление или Корректировка объявления). Дальше расположен непосредственно текст объявления (кроме текста объявления здесь отражаются номера телефонов, относящиеся к нему, тексты к телефонам и адрес). Следующий столбец — это стиль объявления (только если объявление Платное или Льготное). Дальше — это оставшееся количество выходов объявления. Сразу за ним расположено поле Имени оператора, который последним работал с этим объявлением. И в завершении расположен столбец, в котором отражено количество указывающее сколько раз объявление уже было опубликовано.

Замороженные — в отчет будут включены только замороженные объявления.

Отчеты, формируемые при установленной опции Сортировать по телефону имеют несколько другой формат.

Вот такой вид имеет отчет без установленной опции С названиями рубрик (т.е. с номерами рубрик без названий)

Последовательность столбцов:
— код объявления;
— оставшееся количество выходов;
— номер телефона;
— текст к первому телефону;
— номер второго телефона;
— метки "Н", "П", "Л";
— код рубрики;
— текст объявления;
— количество указывающее сколько раз объявление было опубликовано.

Отчет с установленной опцией С названиями рубрик имеет вид:

Итоговая строка: Размер — указывает на общий размер объявлений (в байтах) включая телефоны и адреса, но без названий рубрик. Всего объявлений — общее количество объявлений.


Экспорт данных

Результатом занесения и корректировок объявлений является экспорт данных, сохраняющий обработанные данные в текстовых файлах различных форматов и кодировок.

Экспорт данных осуществляется нажатием кнопки [image], выбрав, предварительно, кодировку и формат данных.

При экспорте данных в форматах Текст для Corel Ventura, Текст для PageMaker и Текстовый файл появится окно Save As, предлагающее указать имя файла в котором Вы хотите сохранить экспортируемые данные и его место расположения. По умолчанию, в качестве имени файла, программа предлагает имя состоящее из названия hello и номера экспортируемого выпуска

Указав имя файла и его месторасположение нажмите кнопку [image].

При экспорте данных в формате Для размещения в Internet будет создан не один текстовый файл, а ровно столько, сколько рубрик и подрубрик занесено в Справочник рубрик, имена экспортируемых фалов будут формироваться из номера рубрики (подрубрики), данные которой в ходят в этот текстовый файл. В состав этих текстовых файлов входит и файл Rubrica.dbf в формате FoxPlus, содержащий расшифровку — какой текстовый файл какой рубрике (подрубрике) соответствует.

В окне Select Directory Вам нужно указать папку, в которой Вы желаете сохранить все экспортируемые файлы, и нажать кнопку [image]:

Завершается экспорт данных окном с сообщением количества экспортированных объявлений

Вы можете экспортировать данные не только текущего выпуска, но и всех предыдущих выпусков (кроме удаленных).


Статистика по выпускам

Из статистического отчета Вы можете получить данные о количестве объявлений всех категорий: Бесплатные, Платные и Льготные. Из отчета также можно получить информацию о наличии Бесплатные объявлений по количеству оставшихся выходов:

В отчете серым выделены Основные рубрики.

Графа Всего кроме "0" и ЗАМОР.. — итоговая графа. Она в себя включает графы: Платные, Льготные и Бесплатные с количеством выходов "1", "2", "3", "4". Т.е. в этой графе отражено реальное количество объявлений в рубрике (подрубрике), попадущих в выпуск. Замороженные не попадают в эту графу

В графах Платных и Льготных участвуют, соответственно, только платные и только льготные категории объявлений. Платные и Льготные объявления с количеством выходов "0" попадают в графу с количество выходов "0".

Графа "0" содержит в себе объявления всех категорий (Платные, Льготные и Бесплатные), с количеством выходов 0 раз.

В графах "БЕСПЛАТНЫХ" с количеством выходов участвуют только Бесплатные объявления. Объявления категорий Платные и Льготные в этих графах не участвуют.

Графа ЗАМОРОЖЕННЫЕ — содержит в себе количество замороженных объявлений.

Графа ВСЕГО — это итоговая графа по рубрике (подрубрике). Эта графа формируется путем сложения содержимого всех граф кроме графы Всего кроме "0". Графа ВСЕГО отражает общее количество объявлений в базе, включая и объявления, которые не попадут в выпуск, но которые можно отредактировать (объявления с количеством выходов "0").


Анализ работы операторов

Анализ работы операторов — отчет в котором отражаются результаты работы операторов. Отчет можно получить за любой период.

В количестве операций отражаются как новые объявления, занесенные оператором, так и все объявления, которые он корректировал. Удаляемые объявления в количестве операций не фиксируются.

Кнопка [image] позволяет удалить из таблицы, содержащей данные о работе операторов, все данные, хранящиеся более 2-х месяцев, и оставить только данные за последние два месяца работы.

Отчет имеет вид:

В нем отражаются дата и время входа в систему и выхода, а также количество операций, выполненное в этот период.


Администратор

Администратор — это пользователь с расширенным кругом возможностей. На него возлагается ответственность за содержимое выпуска и контроль правильности занесения информации. При этом в его распоряжении находятся все инструменты обработки информации, реализованные в программе.

Администратор в праве осуществлять следующие операции, недоступные пользователям:
1). Присвоение текущего номера
2). Работа со Справочником пользователей
3). Экспорт данных
4). Просмотр данных Анализа по операторам
5). Возможность Удаления данных по оператору
6). Осуществлять автоматический Поиск и замену в текстах объявлений
7). Удалять объявления.
8). Продлевать объявления категорий ПЛАТНЫЕ и ЛЬГОТНЫЕ.
9). Корректировать Справочник рубрик
10). Изменять данные о регистрации программы


Справочник стандартных фраз

При занесении текста объявления можно пользоваться Справочником стандартных фраз для выбранной рубрики (предварительно заполненным Справочником типичных фраз и выражений).

Вызвать этот справочник можно нажав функциональную клавишу на клавиатуре F2. Используя интерактивный поиск выберите нужную фразу и нажмите Enter, либо кнопку [image]. При этом в тексте объявления выбранная фраза добавиться в то место где был установлен курсор до вызова Справочника стандартных фраз.